cancel
Showing results for 
Show  only  | would you rather see results for 
Did you mean: 
Need help?

Great fibre broadband but landline now dead

Reply
2 REPLIES 2
Highlighted
First Timer

Connected new router yesterday as per instructions and while fibre is working fine my landline is now dead as a dodo. Followed all instructions re set-up  but 24hrs later still cant make or receive calls. No dial tone either. Working from home so getting a little frustrated. Will I get through if I call customer services? Thought I'd try here first. Anyone experienced similar?

Stephen Fitton
Highlighted
Community Star

This forum works well, but you may have to wait a while for a response as posts are dealt with as queued.


For a quicker reply can you please ensure you have your personal information up to date in your profile. Link here - https://community.talktalk.co.uk/t5/user/myprofilepage/tab/personal-profile:personal-info
If you are unsure of your phone number, you can find this in My Account or dial 17070 from your landline phone and this will confirm the number for you.
Thank you

Please remember to mark Solved Posts with Best Answer. Doing so helps others and saves OCE's time to look at unsolved topics. Thanks, Steve.
Community Team - TT Staff

Hi Mercian99

 

I'm sorry to hear this.

 

The line tests have detected a line fault so I have escalated this over to Openreach to be investigated by a line engineer.

 

We should receive further updates within the next 48hrs.

 

Thanks

 

Debbie