cancel
Showing results for 
Show  only  | would you rather see results for 
Did you mean: 
Need help?

TalkTalk speeds significantly lower than stated, below 0.5mbps.

Reply
Popular Poster

Yeah just to say, my line checks are coming back fine, and they detect no issues with my home setup.

Team Player

*post removed by OP due to factual inaccuracy*

Liam
Team Player

If your aim is to show TalkTalk they cant mess you about, switching to plusnet is like scoring an own goal I believe. You'll just be paying them 77 quid to use the same lines with a slightly different support team.

 

*edit: sorry I got that wrong there. don't believe everything you hear on the street regarding ISPs and their subsidiaries!

Liam
Community Star

@Lbow78 I agree that switching may only shift any issues to a different provider. But just to clarify, Plusnet are NOT a subsidiary of TalkTalk, they are owned by BT. 

Team Player

@ferguson Right you are! I there I go running my mouth, starting beef with the Plusnet mob wantonly. My bad!

 

but yeah @gareth adams, get the line checked by the engineer through talktalk who may be liable to solve it before handing over to another company who owe you nothing and may charge you for repairs.

Liam
Team Player

Hi @OCE_Michelle, has there been any update? Even just to know what the call I received said, my partner was calling me down to the landline and missed the content of the automated message.

Liam
Team Player

@OCE_Michelle @OCE_Chris @OCE_Debbie? Anyone able to provide another update?

Liam
Team Player

No change on my end, just incase anything has been done on your end. 

Liam
Community Team - TT Staff

Hi,

 

Apologies, I've still not received an additional update back as yet so I've chased for an another update now.

 

Thanks

 

Community Team - TT Staff

Hi,

 

Our Network Team have just come back to me now and apologised for the delay and have advised me that they are looking at this fault now.

 

Thanks

 

Team Player

Thanks @OCE_Michelle, No change as of yet, last night I got a high score of 0.8mbps but it was just a fluke, next one was 0.3. I'd have expected something of notice to have happened by now?

Liam
Team Player

@OCE_Michelle, Thanks for getting back to me with this, fingers crossed today is the day for a return to functionality.

Liam
Community Team - TT Staff

Hi,

 

I believe that you've now been contacted. Our Network Team have advised that they have identified a possible issue and we are looking to resolve.

 

Thanks

 

Team Player

Hi @OCE_Michelle,

Yes I spoke with someone from the team who was at first very confused as the issue isn't something thats really been seen before apparently. something going on with TalkTalk hardware locally, it looks like its an issue everyone in my immediate local area is having with Talktalk. This may explain the mysterious arrival of new hubs on my list of available wifi connections, everyone must have been going through the same process. If it weren't for me running so many tests and finding the VPN solution they'd have maybe still been at a loss as to how to proceed as this helped them significantly in identifying the issue and allowed them to replicate the fault and pass that information along to maintenance. I think he said he was going to do so but in any case could you, make sure that other people experiencing this locally are made aware of your efforts to fix it so they don't spend yours or their own time going through the same process as I have.

When this all blows over, I don't know if you award medals for customer engagement and patience, but I'd take a belter of a superfast/speed boost deal instead?

Liam
Community Team - TT Staff

Hi,

 

Thanks for the update. To be honest this was a new one for me too as I haven't seen a fault before were the speed dramatically increases only when using VPN. I'm glad that they have now managed to identify the issue and hopefully they will get to the bottom of this shortly. I will also check back on Monday to see how you are getting on.

 

I'm sorry it has taken a while to identify this and thanks for your patience.

 

Thanks

 

Community Team - TT Staff

Morning,

 

Has there been any change since your last post? If not then I'll check in with our Network Team for an update.

 

Thanks

 

Team Player

Hi @OCE_Michelle,

 

Yes! I'm back to regular speeds as of yesterday!

 

I am expecting a call from the network team who said they'd call back in today to better explain what the issue was and how they fixed it. But yeah, back up and running.

Thanks for your help, I'm hoping to upgrade to a faster deal also, hoping you guys can offer me something much better than your competitors after the last few weeks of bother? Is this something you can assist with?

Liam
Community Team - TT Staff

Hi,

 

I'm really glad to hear this and hopefully they will be able to advise on what the issue was when they make contact with you again 🙂

 

In regards to upgrading to a better deal, unfortunately this is not something that we can look into via the Community. I'd recommend contacting our Loyalty Team directly as they will be able to look into this and advise further.

 

Thanks