cancel
Showing results for 
would you rather see results for 
Did you mean: 
Need help?

Using An Alternative DNS Server On WiFi Hub

Reply
15 REPLIES 15
Highlighted
SiHancox
Super Duper Contributor

Hi,

 

Could anyone please clarify which section under the WiFi Hub web interface is the correct one for alternate DNS’s.

 

The TalkTalk web site states you should go into “TalkTalk WiFi Hub” section as below.

 

A58CE266-2078-43BD-9C2F-43337FE0F4FB.jpeg

 

This is the relevant article from TalkTalk web site.

 

274C62A5-54B6-48AF-9190-77E6DAABB795.jpeg

 

But a recent post I’ve seen states it should be done under the “Internet Connectivity” section by selecting “Manually Specify DNS”, which is the one I’ve currently used to add Cloudflare.

 

7C503EEB-459F-42D1-8361-3ABDA7B34C99.jpeg

So which is the correct location to use, the first image or the last?

 

Thanks.

 

Highlighted
ferguson
Community Star

Both. If you turn the DNS switch to ON you will find that your router IP address becomes the internal DNS server there once you have applied your chosen external servers in the Internet settings. 

Highlighted
SiHancox
Super Duper Contributor

Hi @ferguson 

 

Thanks for replying, I must admit it was your recent post that prompted my question.

 

But if I change DNS to Manual (and enter the new DNS's) under Internet Connectivity then go to the DNS tab under TalkTalk WiFi Hub the switch doesn't work, it stays off as below.

 

Screenshot 2019-12-05 at 15.30.07.png

 

It only seems to work if I go back and change to "Obtain DNS Automatically", then it can be  turned on and I can also enter the DNS's underneath if required.

 

But if I do that the TalkTalk DNS's still show under the Device Info section.

 

Sorry for not getting this, it's just a little confusing.

Highlighted
ferguson
Community Star

OK, I think (!) the sequence is as follows. Leave both sets of settings at default i.e. OFF and Automatic respectively. Then switch the DNS setting to ON. Do NOT enter any server numbers there. Then select manual and enter and apply your chosen servers in the Internet settings.

 

(With apologies for repeated edits!)

Highlighted
SiHancox
Super Duper Contributor

That doesn't seem to work either because you can't just turn on DNS and leave the tab, it prompts for DNS inputs in that section as well.

 

Screenshot 2019-12-05 at 15.57.47.png

 

I wonder if the process requires a reboot.

Highlighted
SiHancox
Super Duper Contributor

If I ignore the DNS switch and just change under Internet Connectivity, these are the settings I get.

 

Screenshot 2019-12-05 at 15.46.36.pngScreenshot 2019-12-05 at 15.47.03.pngScreenshot 2019-12-05 at 15.47.23.png

Highlighted
ferguson
Community Star

OK, that's odd. I just tested on mine. Having had Manual DNS I reset the Internet settings to automatic. I then went to DNS and when it was switched off the TalkTalk DNS server details appeared greyed out. I then turned DNS to ON and 192.168.1.1 appeared in Primary, nothing in Secondary, no prompts.

 

Screenshot 2019-12-05 at 16.06.23.png

 

You haven't otherwise changed your DHCP settings, or router IP address? Are you on the latest software version?

Highlighted
SiHancox
Super Duper Contributor

Hi @ferguson 

 

Sorry about that, lost internet for a while but think with your posts I'm sorted.

 

For whatever reason I lost 192.168.1.1 under the DNS switch, that meant the iMac also hadn't got that under the Network setting, so I basically had no internet.

 

I manually added it in the Hub under the switch section the rebooted iMac and it then appeared greyed out with "lan".

 

I could then leave the TalkTalk WiFi Hub section and go into Internet Connectivity to change DNS's under Manual which gives me the following screen shots.

 

Screenshot 2019-12-05 at 16.48.13.pngScreenshot 2019-12-05 at 16.48.35.pngScreenshot 2019-12-05 at 16.48.51.pngScreenshot 2019-12-05 at 16.50.33.png

 

I think that's how it all should be, and all this was caused by the missing "192.168.1.1" when turning on the Static DNS Server Configuration, the question is why.

 

Should it autofill from the iMac or should it come from the Hub.

 

Anyhow, I hope you are going to confirm the above is all as it should be, and I can start breathing again.

 

Your time and help is greatly appreciated. 

Highlighted
ferguson
Community Star

Looks good to me. You should not need to fiddle with the settings on your Mac, the router IP should be what it shows.

 

Screenshot 2019-12-05 at 17.22.44.png

 

You can check that you are connected to the DNS servers you have selected under Advanced > TalkTalk WiFi Hub > Device > scroll down to Network.

Highlighted
SiHancox
Super Duper Contributor

Yes, the DNS servers do appear correct under the Device Info section.

 

Forgot to add if “Manual” is selected it appears 192.168.1.1 is then greyed out and you can’t turn off the switch, to do anything under DNS you have to go back and turn off Manual, at least on my setup.

 

The only thing now left to resolve is the occasional stuttering of my Music streamer since ...2808t, I believe a meeting is taking place to work out what’s causing WiFi connection issues for a few users, luckily I only have this with the one device though.

 

Anyway, thanks again for your time and time, it’s greatly appreciated.

Highlighted
ferguson
Community Star

No worries, glad to help.

Highlighted
SiHancox
Super Duper Contributor

Hi @ferguson 

 

Could I trouble you and ask a further related question, I posted an image of what appeared to be instructions by TalkTalk on how to change to third party DNS Servers, but it points you to enter the info under the WiFi Hub DNS tab (as below).

 

1E0B4AB8-3616-43F1-B7F6-CC192889CCD2.jpeg

 

So has someone got this wrong or does it relate to another device or is there a specific circumstance when one does use this section, because as we have concluded it’s the Router IP address that should be the only thing populating this section.

 

Again, sorry if this is a dumb question, but I don’t mind admitting all this confuses the hell out of me.

 

Thanks.

Highlighted
ferguson
Community Star

I think that's one for the OCE to answer and I have flagged it up accordingly.

Highlighted
SiHancox
Super Duper Contributor

Now you’ve peaked my interest, should we not have access to that DSN tab then if all it should show is the Routers IP address or is it still necessary to activate what you change and type in under the Internet Connectivity section 😉

Highlighted
ferguson
Community Star

I think you mean piqued.  😉

 

That aside no, the ON/OFF switch in the DNS tab behaves differently depending on whether the Internet settings are auto, or manual. Hence the convoluted process and explanation!

Highlighted
SiHancox
Super Duper Contributor

Nice one, I’m not even going to blame the auto correction on that, just not concentrating on the typing, probably brain too muddled in trying to understand all this configuration stuff 🤪