FIbre Support

Get expert support with your Fibre connection.

Showing results for 
Show  only  | Search instead for 
Did you mean: 

unable to verify the printer on your network

Message 11 of 11

Good evening,

Today I have had my new router installed, we used to have Virgin. Now, my HP Envy 110 printer won't work. It will connect to the network, but my Mac will not recognise it. I have deleted it and tried to add it, but I get the message "unable to verify the printer on your network".  When I go to my talk talk router, I can see the printer is on the 2.4 Band. Will this make any difference? Can I change it to the 5? I am completely lost and losing my patience. Wish I had never moved from Virgin. I need my printer for work and now I can not print anything! Please, any help would be much appreciated.

Many thanks


Message 1 of 11

Hi soniatwin,


Glad to hear that you've managed to resolve the problem with a little help, please let us know if you need any further assistance


Not applicable
Message 2 of 11

Message 3 of 11
sorted! I use the WPS function and nos printer is working and connected to the computer and the router, showing an IP address. Thank you so much for your suggestion, I has saved me spending money on a new printer and hours of frustration!!!

Message 4 of 11

Hi, thank you for your reply. What do you mean by “ using the wps” function? Shall I have the printer next to the router and press  WPS on the router and see if the printer connects? Although when I go to my router settings I can see the printer there, but not IP address associated to it. 


Not applicable
Message 5 of 11



""HP Envy 110 printer""

These have a habit of needing to connect to HP to print, and to order new ink.


So are you on the HP  nightmare?




Not applicable
Message 6 of 11


The most obvious difference is that VM is

VF is


So if your printer is looking for a connection, the best option maybe to use the WPS function rather than change the addressing manually.


IPv4 Address. . . . . . . . . . . :
Subnet Mask . . . . . . . . . . . :
Lease Obtained. . . . . . . . . . : 20 October 2020 09:44:15
Lease Expires . . . . . . . . . . : 26 November 2156 16:51:21
Default Gateway . . . . . . . . . :
DHCP Server . . . . . . . . . . . :
DNS Servers . . . . . . . . . . . :


Daft Idea

You could setup a Guest Network that is the same SSID as the old VM SSID and see if the printer recognises that.


But it is difficult to distinguish between a Wi-Fi problem and Apple OS just being awkward.



Message 7 of 11


I have tried doing that three times this morning, and still getting the same message when adding the printer "unable to verify the printer on your network.

I am not sure if the printer is not compatible with the router, or the router does not support the bonjour Multifunction. My next step will be to connect the printer to the Mac using a usb cable, if I can find one!



Message 8 of 11

Hi Martin,

thanks for your reply. I have tried to restore the software but it turns out that there is not updates for Mac Catalina for the printer. I don't understand because the printer was working perfectly fine until yesterday morning, when we changed the router, which makes me think it is a fault with connecting to the router, although it does say it is connected. 

I do not know what else I could try, maybe buy a new printer!



Message 9 of 11

Yep, delete the printer from your mac entirely and then re-install. If that doesn't work then delete the printer from the network as well as the mac and re-install. Power down the printer as well as in unplug it for 30 secs. 


My mother and father in law have exactly your set up and have the same issue. For some reason the mac suddenly seems to be unable to find the printer every 3-4 weeks even though its still on the same network.


Still, I usually get a Sunday lunch & a couple of beers when i go round to fix it so every cloud eh.



Message 10 of 11

Most printers are 2.4 GHz only and if has successfully connected to your WiFi, leave it as it is.


Have you tried reinstalling the printer software on your Mac ?