Broadband help

For queries about your TalkTalk broadband service.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Router connection constantly dropping

abaddison
Chatterbox
Message 9 of 9
Hello I’m having the same issue as in the ‘router constantly stopping’ post and have the router version mentioned by @Skynet_TX Be great to have the setting fix mentioned as it’s been messing up my work video calls. Thanks
0 Likes
8 REPLIES 8

Message 1 of 9

Hi abaddison

 

I'm so glad to hear this.

 

Thanks for letting us know 🙂

 

Debbie

0 Likes

Message 2 of 9

Hi Debbie, the new router is definitely working better than the last one. Thanks 

Message 3 of 9

Hi abaddison

 

I'm really sorry to hear this.

 

I have ordered you a replacement router, please allow 24-48hrs for this to arrive.

 

Let us know how the connection compares with this router.

 

Thanks

 

Debbie

abaddison
Chatterbox
Message 4 of 9

Hello, I’m still having issues with the router dropping connection several times a day. Just had a painful work video meeting that I couldn’t contribute to as the connection was unstable. Could you send me a new router please? Thanks

0 Likes

Message 5 of 9

OK thanks, if you do experience any further problems please let us know 


Chris

 

 

0 Likes

abaddison
Chatterbox
Message 6 of 9

Hello, thanks both. Just changed the DNS servers and rebooted everything. So far it seems to be working ok. I don’t have a phone so can’t check the line. Thanks. 

Message 7 of 9

Hi abaddison,

 

Has Skynet_TX's advice helped?

 

Line test is passing but also showing some disconnections. Are you experiencing any problems with your telephone service, any noise on the line?

Chris

Skynet_TX
Community Star
Message 8 of 9

Hi @abaddison,

 

If the LED is remaining solid white, but your devices (wired and wireless) lose connection to the internet, and a reboot of the router gets things working again (until it happens again), then you may be suffering from a known DNS resolution issue that affects firmware version SG4K10002816t. There is a new version of firmware that resolves this issue, but the rollout is currently paused whilst TalkTalk make a further small change to it.

 

The staff here could probably provide you with a replacement router of a different type (the Huawei hub), but there is also a small change you can make to the settings of your Sagemcom that in many cases can stop the problem from happening.

 

It is only a good idea to try this if you have a fairly simple home setup (i.e. just devices that need to access the internet), if you have devices that need to talk to each other and rely on your router to provide local DNS for the devices to find each other, then trying this workaround is probably not appropriate, as it may stop those devices from being able to see each other.

 

Here are the details of the change you could try :

 

At present your router will be acting as the DNS server for all of your devices, so when the DNS stops working in your router all of your devices will lose internet access. However you could configure your router so that it just tells all of your devices to use the TalkTalk DNS servers directly, therefore your devices won't use the router as a DNS server, and so shouldn’t be affected if the routers DNS stops working.

 

If you wanted to try this you just need to follow the instructions for the 'Wi-Fi Hub' here (ensure you go to the screen described in this article, as there are two screens in the router where you can modify DNS settings, but you must change the settings on the specific screen described in this article for this potential fix to work). If it won't let you change the settings in this screen it may be because you have set specific DNS servers in the other screen where you can modify the DNS settings, if this is the case then go back and set that other screen back to Auto, that should then allow you to edit the details on this screen.

 

If you have never changed these settings before you will probably find that the primary DNS server is set to 192.168.1.1 (i.e. the router itself). You could change the settings as follows (or use any other DNS service of your choice) :

 

Primary : 79.79.79.79
Secondary : 79.79.79.80

 

These are the current preferred TalkTalk DNS servers (they are mentioned at the bottom of that webpage so you know they really are genuine TalkTalk DNS servers).

 

IMPORTANT : Having changed the settings you would need to make your devices disconnect and reconnect to the router (you could just reboot the devices or the router). When your devices have reconnected they will be configured to use those two addresses above as their DNS servers. So from that point on the devices will use the TalkTalk DNS servers directly rather than going via the routers DNS service.

 

Making this change may well resolve the issues for you, but if you do ever want to 'undo' this change all you need to do is put the old values back into that screen, or you could just factory reset the router by holding in the pinhole reset switch on the back for over 10 seconds, as that will return all settings back to their initial defaults.