cancel
Showing results for 
Show  only  | would you rather see results for 
Did you mean: 
Need help?

No social media sites work on our new fast fibre broadband account.

Reply
4 REPLIES 4
Highlighted
First Timer

We signed up with Talk Talk almost a couple of weeks ago. We can't access any social media site at all! This is rather annoying and is hindering the work we do, I do not want to call customer services as I've read they are not very clued up  and unhelpful.

 

But I came across another thread by @piyushksx  where a new router solved the issue (link below).

 

https://community.talktalk.co.uk/t5/Broadband/Whatsapp-and-Facebook-not-working-on-my-new-TalkTalk-c...

 

We would really appreciate it if some one could look in to this and fix it PLEASE!

 

Thanks in advance,

 

Nagga99

 

Highlighted
Philosopher

Have you checked the HOMESAFE settings in your online account ?

Martin
Highlighted
Community Team - TT Staff

Hi

 

We have found this is caused by HomeSafe (KidsSafe) settings defaulting to 'ON'.  If you turn this off in My Account then all should work as normal.  Our teams are looking at this.

 

Thanks

 

Karl. 

Check & Report l Our latest Blog l Set Your Preferences l Service Status l Help with your Service l Community Stars

Working From Home Tips


Please log in to My Account if you need to view or pay your bill, manage boosts and track your usage. From My Account you can also check your connection and test your line for any issues in the Service Centre.


WEAR A MASK      -      WASH YOUR HANDS      -      SOCIAL DISTANCE

Highlighted
First Timer

Thanks for the info guys, found it and got it sorted.

It shouldn't be activated by default, unnecessary headache if some one is not aware of it.

 

Your guidance was much appreciated!

Highlighted
Community Team - TT Staff

Hi Nagga99

 

Thanks for keeping us updated. Please let us know if you do experience any further issues.

 

Debbie