cancel
Showing results for 
would you rather see results for 
Did you mean: 
Need help?

Dropbox does not connect

Reply
6 REPLIES 6
alexL1
First Timer

Hello - some users seem to have had this problem already, though can't find the solution.

 

Just switched to the talktalk broadband which is working fine except -- my Dropbox account does not connect (nor does their website). Error message is "Secure connection failed". It is not a software issue, as this only occured when I switched the broadband to TalkTalk, and the error message is the same on all devices. Have tried switching the router on and off, and rebooted the machine.

 

Thanks for your help.  

Garton2019
Team Player

Don't know if this will help or not, but I have a vague recollection of a Dropbox issue that was very specific to TalkTalk users some years ago.

 

The problem appeared to follow some Dropbox maintenance and/or upgrade and affected the MTU setting that they found acceptable from the TT network.

 

Can't remember the exact resolution, but if your router's MTU is set to 1500 try changing it to 1492. Or, if your current setting is 1492 try changing it to 1500. It was one or the other.

 

This resolved the old issue, no one explained why, but it worked.

 

But might be worth a try.

Community Team

Hi alexL1,

 

Does this affect wired and wireless?

 

Can you please update your community profile to include your:

  • Name
  • Telephone number
  • Alternative contact number

We'll then look into this further. Please do not post this information on this thread Once you've updated your profile please post in your topic to confirm it's updated. 

 

Thanks

 

Salhammadi
Visitor
My I know why Dropbox is not working. As well some app from my fire stick. Rubbish service from talk talk. Why should I post an article to be helped??????
Salotaibi
ferguson
Community Star

@Salhammadi Please start your own topic to avoid confusion, if you don't tell us what the problem is we can't help.

Salhammadi
Visitor

It give me connection failed when I tried to upload any thing in my Dropbox app or website. 

Salotaibi
ferguson
Community Star

OK, as I said please start your own topic.