FIbre Support

Get expert support with your Fibre connection.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

G.Fast & the Zyxel XMG3927-B50A

OddSocks
Chatterbox
Message 12 of 12

I've bought the Zyxel XMG3927-B50A to replace the Openreach modem & TalkTalk Sagemcom 5364 but I'm struggling to set up the connection via the Zyxel.

 

I'm using the username/password provided by TalkTalk customer service, and have entered this username/password on the TalkTalk router itself and continued internet access.

 

I've tried the settings mentioned here https://community.talktalk.co.uk/t5/Articles/Set-up-a-non-TalkTalk-router/ta-p/2205383 and the Zyxel shows that it can understand that the DSL cable connected to it is at ~300/50 up/down potential but I can't get it to actually connect to the internet.

 

@ItiCIaGUI'm hoping you could give me a hand re your comments on https://community.talktalk.co.uk/t5/Fibre/Thinking-of-migrating-to-fibre150/td-p/2664032

and confirm to me the settings I should be using on the Zyxel?

 

If I manage to get it working I'll of course post in here for anyone else that stumbles onto this.

0 Likes
11 REPLIES 11

Message 1 of 12
Cheers, apart from that I had to set /etc/network/interfaces as well, sorted!

Message 2 of 12

In case you aren't already aware, should be a matter of editing /etc/dhcpcd.conf in the root partition of the SD card. All the best

Message 3 of 12
It was indeed, I'll see if I can set that without being able to ssh in - cheers.
0 Likes

Message 4 of 12

Yeh, I wouldn't lose much sleep over the MTU if you're not experiencing any problems.

 

As for the pi, was it set up previously with pi-hole? If so, worth checking whether the static IP set on the pi by pi-hole still falls within the subnet on your new network.

0 Likes

Message 5 of 12
Yeah, although I've got MTU set at 1500 with no bother and they don't mention the requirement of setting the static IP

Now the only remaining problem I have is I can't see the Pi 4 on the network to use it as a pihole, but that can be a job for another day.
0 Likes

Message 6 of 12

Glad you've got it sorted! Had I received a notification of your previous reply, I would have suggested trying to obtain an address automatically to see where that would get you, so maybe I would have just delayed you further!

 

edit: I was curious, so for reference the settings are apparently under Broadband > Business Fibre > Setting Up & Getting Started > How do I connect a third party router? here: https://supportcentre.talktalkbusiness.co.uk/home

 

If you have a router that isn’t from TalkTalk Business then you'll need to manually enter the Router Connection Settings when setting up your router. The way that you do this will differ from router to router. To find out how to enter the settings on your specific router, you'll need to visit the manufacturer’s online support pages or consult the manual.

Once you have found out how, you can start entering the following details:

Username: this is your telephone number followed by @talktalkbusiness.net eg, 01234567891@talktalkbusiness.net
Password: enter your broadband password here
VPI: 0
VCI: 38
MTU: 1432
DNS settings: Set as automatic (or similar)

If you need to enter these settings manually then they are:
Pimary DNS Server: 62.24.128.17
Secondary DNS Server: 62.24.128.18
Encapsulation: PPP over ATM (PPPoA) using VC-MUX
Modulation Type: Auto

 

 

 

Message 7 of 12

Sorted!

 

Had to use PPPOE, my username/password, specify my static IP, use relevant settings throughout and job done.

I also deleted the ADSL and ETHWAN interfaces, although I assume that was irrelevant.

 

@ItiCIaGUthanks for your help/info, it definitely helped

 

 

working_zyxel_settings.png

Message 8 of 12

G.fast is enabled in there (it looks like everything is enabled by default).

Renew doesn't seem to do anything.

 

xDSL statistics:


    xDSL Training Status:   Showtime
                    Mode:   G.fast Annex A
            Traffic Type:   PTM Mode

 

Same as you've mentioned.

 

In the log, there's plenty of:

 

1    Jan 1 04:18:41    kern    info    dhcpc    udhcpc: Entering released state
2    Jan 1 04:18:41    kern    info    dhcpc    udhcpc: Received SIGTERM
3    Jan 1 04:18:37    kern    debug    dhcpc    udhcpc: Sending discover...
4    Jan 1 04:18:35    kern    debug    dhcpc    udhcpc: Sending discover...
5    Jan 1 04:18:33    kern    debug    dhcpc    udhcpc: Sending discover...
6    Jan 1 04:18:24    kern    debug    dhcpc    udhcpc: Sending discover...

 

I could post a full export if you think it'd help.

 

To confirm, this is only using the Zyxel and not using the openreach modem or sagemcom router at all.

 

If it makes a difference, this is TalkTalk Business and I have a static IP - entering custom DNS (e.g. cloudflare 1.1.1.1 / 1.0.0.1) and the static IP is possible, but not sure what to put for the subnet mask & gateway as this is presumably ISP specific (and is not the standard 255.255.255.0 & 192.168.178.1)

 

edit: potential stroke of luck, the public subnet mask & gateway are in the sagemcom's settings, I'll give them a try.

edit2: nope, no difference

0 Likes

Message 9 of 12

No, haven't touched any of the other interfaces.

 

Worth checking that G.fast is enabled in Broadband > Advanced, although I don't recall having to enable it myself.

 

Assume you've already clicked the 'renew' button?

 

What is in System Monitor > xDSL Statistics? Amongst other things, I have:


xDSL Training Status: Showtime
Mode: G.fast Annex A
Traffic Type: PTM Mode

 

Have a look at System Monitor > Log and change the category to WAN-DHCP to see if the messages indicate anything amiss.

0 Likes

Message 10 of 12

Thanks, we're so close now. Have you changed any other Broadband interfaces? I'm now getting:

 

system info.png

0 Likes

ItiCIaGU
Team Player
Message 11 of 12

Hey @OddSocks, sounds like you're almost there, but you don't need to use the username/password as far as I remember - should be IPoE. Also check you have it applied as the default gateway.

 

My VDSL settings for reference:

 

Screenshot_2021-05-20  Welcome to the Web-Based Configurator .png

 

Let us know how you get on and if it's still not working, happy to work through other screens with you.

0 Likes