cancel
Showing results for 
Show  only  | would you rather see results for 
Did you mean: 
Need help?

DLINK DSL-3782 bridge/modem mode

Reply
16 REPLIES 16
cabbers
Chatterbox

Hi all

Moved house, and stayed with TT. Got a new modem (DSL-3782). I'd like to put it in bridge mode, so the WAN IP passess through to my own router (OpenWRT based). On the old router I had (tiny one, only 2 Ethernet ports), this was possible-but I think with this one, its not? If this is right, could someone recommend a decent DSL router I could do this with (I suppose I could use the old one-but the username/password seemed to be hidden on this new one, so if someone could point me on how to get that username/password, I can try it on the old one 🙂 )

 

Cheers in advance

 

cabs

KeithFrench
Community Star

If you want to put the 3782 into bridge mode and connect it directly to the line nothing will ever have access to the internet. Bridge mode disables all of its routing functions, there for no traffic will be able to route to the router''s public IP address, which is a totally different network.

 

What you really mean is to configure the 3782 into modem mode. The 3782 does not natively support modem mode. However, I have seen a thread where someone did manage this. I will try & find it for you.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

cabbers
Chatterbox

Cheers Keith

I gave up and took the old router-that seems to support "pure" modem mode. Set up PPPoE on it with my username and password, public IP now "sits' on my OpenWRT router. However, the line stats dont look as good on it as the newer one, so I may be looking on fleabay for a VDSL router that is good at *just* being a modem, so i can hand off all routing and wireless functions to my OpenWRT/LEDE router. Any recommendations?

 

I think I have seen the thread about the 3782 working in modem mode-I tried that, with no joy-I could not lease a public IP, trying both PPPoA and PPPoE

 

cheers

 

cabs

KeithFrench
Community Star

Anither approach is to leave the 3782 in default config and connect it to your other router via Ethernet & put that router in bridge mode and disable it's DHCP server. You can then disable the WiFi on the 3782 if you want.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

cabbers
Chatterbox

Hi

Thats what I had before, and I was getting DNS errors on some devices-I much prefer raw modem mode. But thanks for the tip.

 

cheers

 

cabs

KeithFrench
Community Star

I have found the configuration that apparently does work as Modem Mode (despite the first screenshot putting in Bridge mode). This was on a fibre connection.

 

Internet config.png

 

Network LAN Config.png

This does apparently push the public IP address directly to the second router. The user who told me about this was @charlesb224.

 

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

cabbers
Chatterbox

OK-tried this last night but it was late 🙂 so will try again. It might be the 2nd router is not accepting it-but it does with the other router.

 

Will let you know how I get on

 

cheers

 

cabs

charlesb224
Wise Owl

This method does work.  I used it whilst I was inbetween modems and needed to have the WAN IP assigned to my router.

 

I've successfully put the following routers into modem mode:

Talktalk DSL3782

Talktalk HG635

 

the KEY element is to ensure you disable the DHCP server on the Talktalk device, otherwise it will provide a NAT address to your router.  When you disable DHCP server, the DHCP request hits the WAN via the 'bridge' and the Talktalk WAN DHCP server assigns the address to your router.  

 

cabbers
Chatterbox

Nope-no joy-must be my OpenWRT router doesn't want to play.

Tried LLC and VC-MUX, plus PPPoE and PPPoA. DHCP server was disabled as instructed.

So back to the old router.Thanks for the help.

 

cabs

KeithFrench
Community Star

I have never tested this myself.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

EyerexUK
Participant
Works for me as just setup with a Asus 86U Router
OCE_Ady
Community Team - TT Staff

Hi cabbers, as the others have said it should work. Have you got another router you can test with just to make sure it's not your openwrt based one? 


Please log in to My Account if you need to view or pay your bill, manage boosts and track your usage. From My Account you can also check your connection and test your line for any issues in the Service Centre.


cabbers
Chatterbox

Hello

I think I responded further up on this-but I put in my old TT DSL router (small D-LINK) and set up the OpenWRT router to PPPOE, stuck in my username and password-and it works! Not sure if putting in the newer TT router would massively improve things-but the current set-up works, so I'm not touching it. Besides, HyperOptic are just about to start selling in here, so I'll be off/not renewing my contract 🙂 Who-hoo!!

 

Cheers

cabs

charlesb224
Wise Owl

Hey @cabbers

 

Are you on Fibre or ADSL?  If Fibre, are you on Business or Residential?

 

If the answer is Fibre/Residential, then you don't need to use PPPoE, the only requirement is to set your OpenWRT router to Dynamic IP/DHCP to connect to the service if you've configured your TT router as above.

 

Charles

LondonFibreUser
Team Player

@EyerexUK wrote:
Works for me as just setup with a Asus 86U Router

I have followed all the steps above (the screenshots), connected my Asus DSL-AC68U to the DSL-3782 via a cable, connected a PC to the wifi of the Asus, but then I couldn't manage to open the webpage to configure the Asus. How did you access and configure the router?

 

 

192.168.1.1 opens up the TalkTalk configuration

http://router.asus.com doesn't work

I went to the TalkTalk router configuration page, home, connected clients, tried the IPs of the other clients, but the Asus router wasn't there

 

Thanks!

LondonFibreUser
Team Player

For reference, just in case it might be helpful to others:

 

I switched off the Talktalk router. Connected a laptop to the Asus via network cable. Set the Asus to router only as described here: https://www.asus.com/my/support/FAQ/1016292/

 

Then switched off the Asus, connected to the TalkTalk router via a network cable, followed the steps in the screenshots a few posts above, switched off wifi on the TalkTalk router.

 

Finally, I connected the TT and the Asus via cable - note the cable must go in the specific port specified when setting up the Asus as router only.

 

It all worked fine, except there was no internal DNS: \\mynas no longer found the NAS, but connecting to the specific IP address of the NAS worked. Most home users do not have a NAS or similar device whose name needs to be resolved, so they wouldn't even notice.

 

I followed the steps described here:

https://unfinishedbitness.info/2015/05/26/asuswrt-finalized-setup/

to set the internal DNS (LAN on the left bar of the Asus menu -> DHCP and DNS on the right) to the IP of the router (in my case, 192.168.1.1) and it all worked fine.

 

Oh, I also set the WAN DNS to Google's , so Talk Talk can no longer hijack the page if an address is wrong.

loady
Conversation Starter
i too finally got this working, i found that only keeping one of the routers switched on whilst making settings to the other key in this, also i noticed that a few times on the dsl3782, settings were not getting saved, mainly turning off wifi, once i was sure all was set it worked fine, i now have the dsl3782 in bridge mode, connected to a asus N66U router running asus merlin firmware, then in the other room i have a asus RT-N16 also running asus merlin firmware set to repeater mode, this connects to the N66U over wifi flawlessly, i have setup openvpn on the N66U and can connect to it remotley and then turn on my server connected to the RT-N16 via WOL.