cancel
Showing results for 
would you rather see results for 
Did you mean: 
Need help?

Desperately seeking a way round the DHCP problems with the 'Super fast' Sagecom router ?????

ANSWERED
Reply
35 REPLIES 35
PaulM47
Team Player

My daughter (unfortunately) has Talk Talk Broadband. I've just invested time and money in new computers etc. for her, including 'upgrading' to the new router and installing a VPN etc. so I can easily (theoretically !!) sort out any problems remotely. I checked that I can change the DHCP settings in the router as I need to allocate some static IP addresses for the VPN etc.. Last weekend I installed all the new gear, a 220 mile round trip to do so !!

 

I found the router DHCP settings don't work, any changes I make are nor saved. After spending several hours trying to sort the problem, and finding many complaints about this and other problems, I find I have the 'latest' firmware' and the problems persist !!!

 

As a 'workaround' I set my fixed IP addresses at the top of the IP range as the DHCP address allocations were around 100 and, in my experience, DHCP address allocations usually 'stick' with the connected devices. This does not appear to be the case, this morning the router is allocating my fixed IP addresses to other devices, so I've lost my VPN access and problems now exist with the other connected devices !!

 

Has anyone found a workable fix for these unforgivable cockups in the Talk Talk Sagecom router ? The router (supposedly) allows reserved addresses in the DHCP settings. I assume these allow the DHCP server to allocate a specified IP address to a device based on its mac address. Has anyone tried this in the Sagecom router ? Does this work even if the DHCP changes aren't saved ?

 

I'm desperately looking for some sort of fix before I make the 220 mile round trip again to try and fix these problems.

 

Regards

PaulM

 

KeithFrench
Community Star

This is a bug in the current firmware. There is new firmware currently under test that will hopefully sort this.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

PaulM47
Team Player

Thanks for replying. Yes, I realise there's an upgrade in progress from what I've read. Any idea when it's likely to be available ?

 

I really need some sort of solution for next weekend. The only solution I can see is to reserve the static IP addresses (which also may not work) or try and move all my static addresses to the 2-9 range. The latter would be a massive pain as there are several interdependent devices connected and the system has been thoroughly tested here before being installed 😞  I'm reluctant to just take it all out as it took me half the weekend to install it all on the assumption the DHCP system worked !!

 

I assume there must be an admin port open to the internet on the router, is there any way I can gain access to that so I can try these changes remotely ? It may save me another 220 mile round trip if I can find a temporary fix 🙂

 

PaulM

 

KeithFrench
Community Star

Yes you can configure static IP addresses on the devices themselves.

 

No sorry it is impossible to remotely manage the router like that. What you could do is to install RealVNC server or similar on a pc there and forward the port for it on the router and allow it through the PC's firewall next time you are there. Make sure that the port reports open via a port checking website before you leave.

 

Then when remote to the router use a RealVNC client to get into the pc and use that pc browser to logon to the router. You wont be able to test this though if the device running the client is connected to the TalkTalk router at that time.

 

It maybe long winded, but should work fine. I can help a lot with port forwarding if you want, you may also want to use a free DDNS provider as well with the router, again I can help with this.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

PaulM47
Team Player

Thanks again for taking the time to reply.

 

I'm halfway to sorting the problem right now. I have VNC installed on all the PCs (running Linux Mint not Windoze), which is what the VPN facilitates access to. The VPN is running on a Raspberry Pi (PiVPN), accessed using a free DDNS server, updated by DDclient on the pi, and port forwarding in the router. I have access to the router using the Chrome browser on the raspberry pi.

 

Rebooting the router unblocked my VPN access. The router appears to have a preference for randomly allocating the four static IP addresses I've set up to other devices on the network, hence setting up address clashes which are causing the problems. I've changed everything bar the VPN back onto dynamic addressing and will generate a script on the pi using nmap to give me an address map for VNC access to the PCs. Unfortunately the PC network names aren't usable through the VPN.

 

The only change I can't do remotely is the VPN IP address as port forwarding will need to be changed in the router as well, and I can't do both while using the VPN 😞 I'll change the VPN static IP address to 2...9 when I get the chance, for now if I lose access I can get my daughter to reset the router, she can understand how to do that 🙂

 

Thanks again for your help, as you say, a bit of a long winded solution but it will save me another 220 mile drive for now 🙂 Hopefully TT will see sense and give us back working admin pages on what is otherwise a very good router.

 

Regards

PaulM

 

PaulM47
Team Player
Solution

Ok, this is my workaround for the TalkTalk Sagecom DHCP problem (for anyone who may be interested) :

 

I have a Raspberry Pi with VNC and SSH enabled, running PiVPN, ddclient and Remmina.
The Raspberry Pi (will have) static IP address 192.168.1.5, everything else is set to DHCP.
The PiVPN is accessed remotely using the Dynu.com DDNS server updated by ddclient.
The router has port forwarding pointing to the PiVPN.
I can remotely connect to the Raspberry Pi using VNC (or SSH).
Using Google Chrome on the Raspberry Pi I have access to the router admin pages.
All the local network PCs have a VNC server installed.
Using Remmina on the Rasberry Pi I can connect to all the local PCs by network name.

 

Not ideal using serial VNC connections, but it works and I don't have to continually look up the network IP addresses.

 

As a matter of interest, the Raspberry Pi is running from a small float charged 12v battery through a 5.1V 4A DC-DC converter. It also has a USB hard disk attached providing a shared NAS device for the network. Self contained, with a built in UPS, it provides all the additional network services required 🙂

 

Regards
PaulM

 

PaulM47
Team Player

Is there also a problem with the port forwarding with this router ??

 

Every couple of days I'm losing the ability to connect to my VPN. It's not an IP address clash, and it's not related to TalkTalk changing the external IP address as far as I can see. Everything unrelated to the router appears to be working fine. If I restart the router, I get access to the VPN back, which suggests the port forwarding is failing ??

 

I've recently found the BT Home Hub 6 I use with my FTTP connection is made by Sagecom, and that has worked flawlessly through a multitude of re-configurations. Pity TalkTalk can't do as good a job as BT have !!

 

Regards

PaulM

 

KeithFrench
Community Star

There are no port forwarding issues with this router at all. Please can you supply screenshots of what you have setup in the router, so as I can check them for you?

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

PaulM47
Team Player

Thanks (again) for your reply. There's not really much to set up, screenshots as requested ...

 

TTPF1.jpgTTPF3.jpg

KeithFrench
Community Star

Exactly how are you testing this UDP port, no UDP port is compatible with online port checking sites and will, therefore, report closed. 

 

You will not be able to test, or use port forwarding from a device on your local network making a connection to your WAN IP address, or DDNS URL. If you did, the connection attempt would be routed out to the internet and back in again to your router. Once it comes back into your router again, it will not be forwarded to the device your port mapping rules state, but will be blocked by the router. This is known as “Loop back” traffic, which most routers will discard those packets as an additional security measure.

 

If you have a Smartphone temporarily disable the Wi-Fi and turn on Mobile Data, which will enable you to test access to the device via your mobile phone network.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

PaulM47
Team Player

Thank you yet again for responding.

 

Yes I agree, it's not possible to test the port forwarding and VPN access from the same network, and yes I use a mobile data connection from my phone when testing this way. I think you have misunderstood what I am doing.

 

The TT router is at my daughters house. I'm 110 miles away. The port forwarding on the TT router allows me access from here, via the internet, to the RPi VPN running on my daughters network. To do this I use a DDNS service, updated by ddclient on the RPi at my daughters house. Using the DDNS network name I can connect to the TT router, and hence the VPN on port 1194. This is completely standard, as is using UDP port 1194 for a VPN. 

 

This works perfectly for a couple of days, that's how I captured the screen shots posted yesterday, then I cannot make a connection to the VPN from here. It's done it again this morning ! My daughter resets the TT router and within a couple of minutes I have the connection back. I've checked the web DDNS server and their external IP address hasn't changed, nothing has changed in the RPi or VPN on her network and nothing has changed here, hence my conclusion that it's the TT router port forwarding that has somehow failed.

 

I've had an identical RPi VPN running here 24/7 for weeks, behind my BT hub and a software firewall, with no access issues from my daughters network. My granddaughters laptops connect to it every day, using the same DDNS service, allowing me to restrict their web usage. Their laptops even run the same version of Linux as I use on my desktop PC here. 

 

The only other possible change I can make, when I next visit my daughter, is to change the VPN IP address from 188 to 5 as planned. However I've seen no evidence of IP address clashes on address 188, all of the DHCP address allocations from the TT router are currently in the 100 to 130 range. 

 

I'm beginning to think the only solution is going to be for my daughter to change ISP, except she has a 24 month contract, or I just buy a decent, fully functional router to replace the crippled TT router !!

 

Thanks again for your replies.

 

Regards

PaulM

 

PaulM47
Team Player

I'm getting *really* fed up with these problems. Every other day I'm losing access to my VPN !!! I planned on doing some updates today as my daughter is out, she's not there to reset the router, yet again, so I have no access !!

 

When are TalkTalk supposed to be releasing the update that should (??) sort out these problems ? If it's not in the next few days my only solution is to buy a router that works and use that to connect to my daughters TalkTalk connection.

 

If I have to do this, which routers are known to work *reliably* with TalkTalk and where do I find the credentials I need to connect it to the TalkTalk account ?

 

Regards

PaulM

 

PaulM47
Team Player

An update.....

 

I've put up with this problem for now as I haven't had the opportunity to replace the TT router just yet.

 

I've been monitoring the changes on my VPN connection. The port forwarding in the TT router appears to fail every time the external IP address changes. It's not the DDNS server I use, that reports the address change within 15 minutes of the change. I've waited up to 8 hours to make sure the IP change has rippled through the web DNS servers.

 

I have two identical systems, a forward VPN connection from here through the TT router to the remote VPN server and a reverse connection from the remote network back through my BT hub to my local VPN server. Everything is identical, same Linux OS, same DDNS server, same PiVPN server set up in exactly the same way. The only difference is the remote TT hub and my local BT hub. The connection from here to the TT router fails every time the external IP address changes, only sorted by resetting the TT router. The connection from the remote network to my VPN server hasn't been touched in months, it just works ! ..and yes my external IP address changes with no problems.

 

My conclusion - there must be a problem with port forwarding in the TT router whenever the external IP address changes.

 

PaulM

 

PaulM47
Team Player

As per private messages with OCE_Karl/OCE_chris. Please update router firmware tomorrow, 1st November.

 

PaulM

 

digitalham
Team Player

If that's the current TT Hub (Sagem) then you can alter the DHCP server setting on it to resrict the range and use your own fixed IPs outside that range but I see no reason why you are having problems with reserving IP addresses as that seems to work Ok on the one I have.

 

For instance I currently have the DHCP pool set to 10 to 254 rather than the 2 to 254 I think it has by default.

 

I'm hoping the tip I saw to leave it off overnight will fix the current issues I am having to get my own Asus router working again after a temporary swap to the TT one while my speed complaint was being worked on to rule out my router as an excuse.

 

 

PaulM47
Team Player

Hi, thanks for updating the Sagecom router, the update was fine, but there are still some issues. I've included a description below in the hope it may prove useful...

 

The DHCP settings now work and are saved properly. I restricted the DHCP IP range to 10..150 and set up my static IP addresses in the range 180..199 as originally intended. This appeared to work fine initially. However ... I have the VPN server and one desktop PC connected to the wired network and two laptops on the WiFi network. There are typically six other mobile devices on the WiFi network. The desktop and laptops exhibited 'freezing' of the data flow, i.e. no data flow at all, for several tens of seconds at a time. This was most noticeable when running OS updates, some of the web connections failed with a server timeout, hence the OS updates failed. After some trial and error I found the way around this was to restore the DHCP range to 10..254 and set up reserved addresses for the four static IP addresses I use. All four still have static IP addresses set locally and do not use DHCP. This arrangement does not now appear to suffer from the 'freezing' problem.

 

When setting the reserved addresses the 'Device List' did not always show all of the connected devices, even though they were all up and had been for a while. I had to try several times to add all four static IP addresses to the reserved list, quitting to the Dashboard and re-running the advanced setup until they showed up and allowed me to add them.

 

At present port forwarding to the VPN appears to be Ok but the external IP address has not changed yet !

 

We had a power cut on Saturday evening. When the power came back up the WiFi didn't, the router had to be reset to bring up the WiFi.

 

...and a request. Please accept that users backing up the configuration are moderately intelligent. At present the backup blindly writes a backup file to the local Downloads folder, no questions asked !! Either include the date and time in the file name (preferred) or ask for a file name, giving the default one if need be.

 

Regards
PaulM

 

Community Team

Hi PaulM47

 

Thanks for your reply.

 

I have passed your feedback over to our Products Team to take a look.

 

Debbie

PaulM47
Team Player

The firmware update hasn't solved the port forwarding problem. The external IP changed earlier today and I lost access to my VPN once again. I left it several hours before restarting the router, which solved the problem as usual. This is going to be the killer as far as I'm concerned !!

 

PaulM

 

digitalham
Team Player

Have you considered using a remote desktop app such as AnyDesk for your remote support? That does not require you to do any port forwarding.