cancel
Showing results for 
would you rather see results for 
Did you mean: 
Need help?

New Wi-Fi Hub. Issue with ethernet connection.

Reply
30 REPLIES 30
Jimboy
Team Player

My uprade to fibre went live on Thursday 14th.

I have found my new TalkTalk Wi-Fi Hub has an issue.
It wont connect my main device which is a windows pc to internet via ethernet cable (I have tried several). I can log in to the router page which tells me my pc is connected, but when trying to go online, it wont connect and windows troubleshooter suggests there is a dns problem and to contact my ISP.

I notice others are having an issue with wifi on this router but my wifi devices all work fine with it.

I am now using an HG633 router which I had, to connect to the internet (ethernet and wifi) and everything is working correctly but would prefer to use my Wi-Fi Hub for the improvements which it has.

I spent several hours communicating via mobile text to the TalkTalk help section but no progress was made and after answering the same irrelevant questions (mainly about wifi) over and over I eventually lost the will to live .. (nearly ha-ha.)

How can I resolve my issue with no internet connection to my pc via ethernet cable with the TalkTalk WI-FI Hub?

ferguson
Community Star

OK, so you can connect to the router via ethernet i.e. login to the interface, but it won't let you access the internet? Which version of Windows are you using? Have you checked that all network drivers are up to date?

Jimboy
Team Player

Hi Ferguson, thank you for your response.

I can log in to the router interface with the wi-fi hub but can't access the internet.

I am using windows 7. I have the latest network adaptor driver.

I am using an HG633 router at the moment which works fine both ethernet and wifi.
 

ferguson
Community Star

OK, so it seems there is nothing amiss with the LAN port, or ethernet connection between router and PC. Beyond that I am stuck as I don't know much about Windows/PCs, hopefully other members may advise. Other than that I have flagged this up to the support team, but they won't be back online until Monday.

Jimboy
Team Player
As a matter of interest I also had my Sky box connected via a LAN port with the wifi hub and connection was ok, allowing me to use catch up etc. if I so desired so it would seem, as you say, there is nothing amiss with the Lan ports.

Thank you for flagging this to the support team. I will wait for a response from them in due course.
ferguson
Community Star

Well, that also suggests there is nothing wrong with the hub if it is providing a wired LAN connection to your Sky box. I would concentrate on the PC tbh.

Jimboy
Team Player

 


@ferguson wrote:

Well, that also suggests there is nothing wrong with the hub if it is providing a wired LAN connection to your Sky box. I would concentrate on the PC tbh.


I think you may well be right and had the same thought, but the fact that the alternative TT router I am using connects flawlessly is giving me second thoughts.

Perhaps the support team can throw some light on the ethernet issue. I live in hope. Thanks again for your advice.

KeithFrench
Community Star

I don't have any problems with my Ethernet connected Windows 10 PC and the new WiFi hub. Are you being allicated a default gateway address? 

Please open a command prompt window (assuming a Windows OS) by going to:-

 

Start > Accessories > Command Prompt

 

In Windows 10, click the Window Icon & type:-



cmd


in the search box next to it. This should find the "Command Prompt" from there.

 


Once there, issue this command in the command prompt window:-

ipconfig /all

Then copy the command window output & paste it here.

 

To copy text from the command prompt, please see this site:-

 

http://www.howtogeek.com/howto/windows-vista/copy-to-the-clipboard-from-the-windows-command-prompt/

 

Things are even easier in Windows 10, just highlight the text & press CTRL-C and paste it into Notepad (to try & preserve the formatting) & attach the file at the bottom of your post.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

Jimboy
Team Player

@KeithFrench wrote:

I don't have any problems with my Ethernet connected Windows 10 PC and the new WiFi hub. Are you being allicated a default gateway address? 

Please open a command prompt window (assuming a Windows OS) by going to:-

 

Start > Accessories > Command Prompt

 

In Windows 10, click the Window Icon & type:-



cmd


in the search box next to it. This should find the "Command Prompt" from there.

 


Once there, issue this command in the command prompt window:-

ipconfig /all

Then copy the command window output & paste it here.

 

To copy text from the command prompt, please see this site:-

 

http://www.howtogeek.com/howto/windows-vista/copy-to-the-clipboard-from-the-windows-command-prompt/

 

Things are even easier in Windows 10, just highlight the text & press CTRL-C and paste it into Notepad (to try & preserve the formatting) & attach the file at the bottom of your post.


Hi Keith

I have followed your advice (apart from the copy/paste bit as yet) and I have found I am being allocated a default gateway address.

 

Default Gateway . . . . . . . . . : 192.168.1.1

 

But,at present, I am using the alternative router and am not sure if I will get a different result with the Wi-Fi Hub connected.

If that might be the case, I will reconnect the wi-fi hub tomorrow and see what result I get.

Thank you .. Jim

KeithFrench
Community Star

Before an IP packet can be transmitted, it not only needs to know the destination IP address, it must also know the destination MAC address.

 

The problem is if you don't your default gateway address (IP address of your router) will route any packets to the MAC address of your old router, not the one of your current router. This is because the PC will not try & get the MAC address of the current router, as it already knows the MAC address of 192.168.1.1. However, that has the MAC address of your old router associated with it.

 

If you keep changing routers, it is always best to restart the PC to clear your ARP cache, or issue this command in the elevated command prompt to do the same:-

 

arp -d *

 

 

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

Jimboy
Team Player

Hi Keith

I wonder if you or anyone else with more knowledge than I in this area could advise on the following:

 

I have compared the ipconfig /all  results on both routers
 and have come across this. The faulty Hub DNS servers look iffy to me.

 

(Faulty Wifi Hub)  DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
                                       fec0:0:0:ffff::2%1
                                       fec0:0:0:ffff::3%1
   NetBIOS over Tcpip. . . . . . . . : Enabled
   Connection-specific DNS Suffix Search List :
                                       lan

 

(Working HG633)  DNS Servers . . . . . . . . . . . : fe80::1%10
                                       62.24.128.18
                                       62.24.128.17
   NetBIOS over Tcpip. . . . . . . . : Enabled

 

Also there is no Connection-specific entry on the HG633 result. Perhaps this could be a pointer to my issue. If so,is there a setting on the Wi-fi Hub (or pc) which could rectify this?

 

Another thing I have discovered when using the HG633 router is if I disable IPV6, the ethernet connection stops working (just like the Wi-Fi Hub) but all is fine when I re-enable it.

Unfortunately, the ethernet on the faulty Hub doesn't connect my pc to the internet whether IPV6 is enabled or not.

KeithFrench
Community Star

Please can you get me the complete display & paste it into Notepad to keep the formatting, print to a PDF & attach it here. Those DNS servers are IPv6 ones, not IPv4.

 

You may well not be looking where you need to in the output from ipconfig /all.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

Jimboy
Team Player

Thanks for your response Keith. Not sure how to attach but have done a copy/paste. Hope you get the info from it.

By the way, I have uninstalled/re-installed my network adaptor driver and no longer have the IPV6 issue I mentioned previously with the working HG633, but no change, unfortunately, to my issue with the Wi-Fi Hub ethernet.

 

(wi-fi hub ipconfig results).

Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation.  All rights reserved.

C:\Users\Jim>ipconfig /all

Windows IP Configuration

   Host Name . . . . . . . . . . . . : Jim-PC
   Primary Dns Suffix  . . . . . . . :
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No
   DNS Suffix Search List. . . . . . : lan

Ethernet adapter Local Area Connection:

   Connection-specific DNS Suffix  . : lan
   Description . . . . . . . . . . . : Realtek PCIe GBE Family Controller
   Physical Address. . . . . . . . . : 20-CF-30-13-B1-DC
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   IPv6 Address. . . . . . . . . . . : fdaa:bbcc:ddee:0:c099:a883:d78b:9fe5(Pref
erred)
   Temporary IPv6 Address. . . . . . : fdaa:bbcc:ddee:0:545b:efef:dc49:4fe6(Pref
erred)
   Link-local IPv6 Address . . . . . : fe80::c099:a883:d78b:9fe5%15(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.1.10(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Lease Obtained. . . . . . . . . . : 17 June 2018 10:15:29 AM
   Lease Expires . . . . . . . . . . : 18 June 2018 10:15:29 AM
   Default Gateway . . . . . . . . . : 192.168.1.1
   DHCP Server . . . . . . . . . . . : 192.168.1.1
   DHCPv6 IAID . . . . . . . . . . . : 304140080
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-14-1E-91-C8-20-CF-30-13-B1-DC

   DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
                                       fec0:0:0:ffff::2%1
                                       fec0:0:0:ffff::3%1
   NetBIOS over Tcpip. . . . . . . . : Enabled
   Connection-specific DNS Suffix Search List :
                                       lan

Tunnel adapter isatap.{DB856550-CED7-4B2A-A7B7-C0842F62B69E}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Teredo Tunneling Pseudo-Interface:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

.............................................

 

 

KeithFrench
Community Star

Hi @Jimboy

 

You are being allocated a correct default gateway IP address, see this part of your last post:-

 

 

Ethernet adapter Local Area Connection:

   Connection-specific DNS Suffix  . : lan
   Description . . . . . . . . . . . : Realtek PCIe GBE Family Controller
   Physical Address. . . . . . . . . : 20-CF-30-13-B1-DC
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   IPv6 Address. . . . . . . . . . . : fdaa:bbcc:ddee:0:c099:a883:d78b:9fe5(Pref
erred)
   Temporary IPv6 Address. . . . . . : fdaa:bbcc:ddee:0:545b:efef:dc49:4fe6(Pref
erred)
   Link-local IPv6 Address . . . . . : fe80::c099:a883:d78b:9fe5%15(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.1.10(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Lease Obtained. . . . . . . . . . : 17 June 2018 10:15:29 AM
   Lease Expires . . . . . . . . . . : 18 June 2018 10:15:29 AM
   Default Gateway . . . . . . . . . : 192.168.1.1
   DHCP Server . . . . . . . . . . . : 192.168.1.1

 

Did you also do this that I recommended a few posts back:-

 

If you keep changing routers, it is always best to restart the PC to clear your ARP cache, or issue this command in the elevated command prompt to do the same:-

 

arp -d *

 

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

ferguson
Community Star

Fantastic ongoing help @KeithFrench I wouldn't have had the faintest idea! And I am so glad I don't have a Windows PC!!

Jimboy
Team Player

Thanks again Keith for your response and time.

 

Yes, I have cleared the ARP cache and also re booted my pc (several times). with no joy. I also rebooted my Hub to no effect.

 

I try not to reboot/swap my routers too much as I fear this may be seen as an issue with the line management system and slow me down.

 

At the moment I am obviously connected with my HG633 and have no plans to reconnect the

Wi- Fi hub until I have something to try which might work.

 

I would really like to get the Hub working with my pc as I have found via my wife's wifi tablet that the download/upload speeds and wi fi performance are noteably superior to the HG633.

 

Thanks again .. Jim.

KeithFrench
Community Star

 

If it works on WiFi ok and you are being allocated a default gateway, apart resetting the IP stack on the PC, this is strange.

 

From the command prompt again, can you ping Google with:-

 

ping google.co.uk

 

and copy & paste the output into your next reply.

 

Currently I cannot see anything obvious to indicate to me that the router is at fault, but that is not to say it isn't faulty.

 

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

Jimboy
Team Player

Hi Keith

I have done as you asked, but of course this is with my working router so I'm not sure it would tell you anything. I am also not sure if I could ping with a command prompt with my non connecting Hub.
 If that's possible I will connect it tomorrow and see what I get.

 

I'm sure you must be fed up with me by now. I agree with  Ferguson when he said 'Fantastic ongoing help'. Not so sure about the 'Windows PC!!' bit though, but he might be right ..ha-ha.


Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation.  All rights reserved.

C:\Users\Jim>ping google.co.uk

Pinging google.co.uk [216.58.208.131] with 32 bytes of data:
Reply from 216.58.208.131: bytes=32 time=26ms TTL=54
Reply from 216.58.208.131: bytes=32 time=26ms TTL=54
Reply from 216.58.208.131: bytes=32 time=26ms TTL=54
Reply from 216.58.208.131: bytes=32 time=26ms TTL=54

Ping statistics for 216.58.208.131:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 26ms, Maximum = 26ms, Average = 26ms

KeithFrench
Community Star

No sorry, that is meaningless done on your HG633, I would need to see the results of the ping when you are using the Wi-Fi hub.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

Jimboy
Team Player

Hi Keith

 

I did a ping to google with my wi-fi hub connected..google not found.

 

I did the full set of netsh commands and reboots etc. to reset pc internet adapter and so on... no luck.

 

I then decided to do a router reset with the pin method...and VOILA!!!...everything working perfectly and flying.

 

I feel a bit sheepish for not trying a reset earlier but I console myself with the fact it was a brand new router out of the box and why would it need a factory reset??

 

Thanks again to you and Ferguson for all your help and please unflag me from the  Community Team queue.

 

Best regards .. Jim.