FIbre Support

Get expert support with your Fibre connection.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Port Forwarding problem - Sagemcom router

steve1234
Team Player
Message 10 of 10

I have set up Port Forwarding in my Sagemcom router as per the usual method I have done with other routers, ie

 

Service = CCTV, Protocol = TCP-UDP, Ext Host = blank, Internal Host 192.168.1.xxx

External Port = 1234, Internal Port = 1234

 

When I check if the port is open (using https: // portchecker . co) it reports that it is.

However I cannot access the CCTV DVR as is normal on previous routers.

 

Are there any other settings I need to be aware of?

 

It will most likely be an error on my part, but could anyone please confirm that they have actually successfully used Port Forwarding in the Sagemcom router, with such as a CCTV DVR.

 

Thanks for looking

Steve

 

0 Likes
9 REPLIES 9

KeithFrench
Community Star
Message 1 of 10

You're very welcome.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

0 Likes

steve1234
Team Player
Message 2 of 10

Thanks Keith

I see from your posts that you have a vast amount of knowledge on all things, especially to do with networks.  It is reassuring that their are people such as you who freely give your time to share it in order to educate and help others.

All the best

Steve

0 Likes

KeithFrench
Community Star
Message 3 of 10

NO worries, I was only going on the information given.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

steve1234
Team Player
Message 4 of 10

Thanks Piethorne for 'butting' in!

 

Super, that was the problem.  Your explanation was most welcome and it shows that the device only likes Port 80.  When changed to that I get access.

 

Many thanks both to you and Keith for spending time to talk me through everything, which is much appreciated.

Steve

 

0 Likes

Piethorne
Whizz Kid
Message 5 of 10

Hope nobody minds me butting in 😁

 

@steve1234You say you are using internal port 1234, however if you can access the DVR/NVR interface in a web browser simply by entering its LAN IP address and nothing else, it implies the device is set to use the default HTTP port 80, otherwise you could not access it without adding the port number to the LAN IP, for example 192.168.0.XXX:1234

 

Typical DVR/NVR settings are something like:

HTTP port 80 & HTTPS port 443 - used web browsers either locally or over the internet
Server / Media port 9000 - used by manufacturer specific software and phone apps
RTSP port 554 & RTMP port 1935 - used to live stream by apps like VLC or on Youtube
ONVIF port 8000 - for access by third party software

 

When you access the DVR/NVR with a web browser, you are using the HTTP or HTTPS ports. So unless you've changed the HTTP port in the device to 1234, it's almost certainly set to port 80. However, that doesn't mean the DVR/NVR isn't using port 1234 elsewhere, which is why it shows as open.

 

Can you access the DVR/NVR from outside of your LAN if you change the Sagemcom's port forwarding rule's Internal Port to 80 ?

 

EDIT: Don't forget to clear out the browser cache before trying.

I'm just a customer who might be able to help, not official help & support.

steve1234
Team Player
Message 6 of 10

Hello Keith

I understand about NAT loopback being blocked, that is why I accessed the WAN from 'outside' the home network over the internet, as per my post, which was:

'However, when I access from outside the network over the internet, by entering the actual TT WAN IP address of my home, it does not get through to the device and I cannot get a setup page'.

 

This was done 2 - ways, via mobile phone over mobile data network only (no WiFi) as you say, and also from an office in town... both 'outside' over the internet and not within the local home network.

 

May I ask, have you actually port forwarded, eg 1234, to a device/server and from 'outside' over the internet and can you access the data/web page/settings of that device (getting the same data/web page from the device when accessed over the internal network), rather than just seeing the port is open and then presuming all is well.

 

Thanks

Steve

 

0 Likes

KeithFrench
Community Star
Message 7 of 10

Nearly all Talk talk routers block NAT Loopback. Any attempt to send IP traffic from a device locally connected to your router out to the internet & straight back in again is blocked.

 

The best thing to do is to disconnect the WiFi on a smartphone and test using mobile data.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they? 

steve1234
Team Player
Message 8 of 10

Hello Keith

Thanks for looking.  To clarify:

 

Yes, it is an * in the External Host field, which I expressed as being a blank entry.  I should have been more clear.

 

The CCTV is at a fixed IP address.  I do this either by MAC reservation or setting it as fixed in the actual device.  The device is at my fixed IP, proven by pinging and being able to access it over the internal network OK.

 

When I test using Port Checker, it does say that the port is OPEN, as per my post.  However, the problem is this:

 

When using my browser on the internal network and I enter the fixed IP address of the device 192.168.0.xxx (note my network is on .0. and not .1.  in case you point that out thinking I was unaware), I can get the device's setup page OK.  Everything is fine.

 

However, when I access from outside the network over the internet, by entering the actual TT WAN IP address of my home, it does not get through to the device and I cannot get a setup page.  However the port does report as being open from outside over the internet and so that is why I was wondering if there is anything in the router which could be blocking data getting in/out, ie is there some other setting I have missed.  (I get someone else to try this to ensure the data is coming from 'outside' and it is not me trying to access my own WAN ip address from 'inside').

 

When I had my previous DLINK router, this port forwarding worked fine, hence me raising this query aboutthe Sagemcom router (which I think is an excellent device) as it is giving me a bit of a problem.

 

Thanks

Steve

0 Likes

KeithFrench
Community Star
Message 9 of 10

The external host should not be blank but have the default entry of an asterisk (*). Other than that there is nothing wrong with your configuration. I have just successfully forwarded TCP port 1234:-

TCP 1234 PF Rule.png 

 

 

TCP 1234 PF Test.png

You will have to either give this device a DHCP Reserved IP address or allocate it a static address on the device itself, which must be outside of the DHCP IP address range.

 

Is the port actually TCP or UDP, as that affects testing.

 

Exactly how are you testing this?

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please set Accept as Solution from the 3 dot menu.
TalkTalk support and Community Stars - Who are they?