cancel
Showing results for 
would you rather see results for 
Did you mean: 
Need help?

Faulty Router?

Reply
10 REPLIES 10
Pixel0801
First Timer

I have the new TalkTalk Wi-Fi Hub running using an Ethernet connection to my PC and I believe it is faulty.

 

For over 3 months I've been in contact with talktalk to try and sort out my internet problems. weekly the connection will drop to nothing and I am having to hard reset the router to get anything.  This worked sporadically until today when even though the router is saying that I'm connected at 13.2 mbps down and 1.0mbps up but have no throughput at all with the latest speedtest result 0.32mbps down and 0.4mbps up..

 

The helpline staff want to go through all the scripted responses but without actually seeming to do anything to help. Getting me to change Wireless Channels even though I'm using it wired. They are saying they cannot find a fault with the line but are willing to send out an engineer which could be chargeable.

 

Surely its the router at fault.

KeithFrench
Community Star

I have asked one of TalkTalk's OCEs to pick your thread up and investigate it for you. To aid the diagnosis, please can you state what happens to hub's LED on the front when this happens? Obviously, you should not have been asked about wireless channels, that is ridiculous when you use it wired.

The forum is not real-time 24/7 support, so depending on how busy they are & how many are working at any one time, this can take 24 - 48 hrs (excluding weekends & limited cover on Bank Holidays). Alternatively, you can call the call centre or use online chat. The posts are responded to in time/date order, oldest first. So the fewer entries you make on your thread now, the sooner they will pick it up.

To save yourself time, please make sure that your community profile includes your first & last names, broadband phone number & if possible an alternative contact number. This can be done by clicking on your Avatar picture then click on "My Settings" followed by:-

Personal Profile > Personal Information

Otherwise, TalkTalk will not be able to tie up your forum username to your broadband account. Only you & TalkTalk have visibility of your details.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

Community Team

Hi Pixel0801

 

I'm really sorry to hear this.

 

I can send a replacement router for testing, would you like me to arrange this?

 

Thanks

 

Debbie

Pixel0801
First Timer
Hi, so the router always displays a solid white light. It never actually drops the connection, however it becomes unusable. I have to reset it by poking the restet button in the back often, I have had to do this multiple times a day at the moment. It's almost like the router has frozen. It's actually at a point where the reset doesn't even work first attempt at holding it now. I'm having to use mobile data just to get this reply over. I will check my profile now.
Pixel0801
First Timer
Hi, yes please. I'm convinced it is indeed the router that is no longer working. It seems to just freeze in solid white light connected state but no longer connect to anything, or drop the speed to unusable. I should point out I had a power cut in the night a couple of months back and it's been considerably worse since then. Also I can't just turn it off and on again, as if I do that, the router will 'connect' with white light etc but no devices work. I get the '!' Next to my wifi symbol on every device until I hard reset the router at the back. I was having to do this every couple of weeks yet I've had to do it multiple times a day at the moment just to get anything.
Community Team

Hi Pixel0801

 

The replacement router is on its way, please allow 24-48hrs for this to arrive.

 

Let us know how the connection compares with this router.

 

Thanks

 

Debbie

Pixel0801
First Timer
Thanks Debbie, I will update when it arrives and I have tested, thanks again for the swift response.
Community Team
Pixel0801
First Timer
Hi Debbie,

I'm afraid the router has yet to arrive, it didn't turn up today like I thought it would, nor any note of it being attempted to be delivered. Sad to say the speed/connection issues are still very much present.
Pixel0801
First Timer
I am still having very much the same problems with my connection. It can't keep my speed for longer than a couple of hours, sometimes it fluctuates so much it drops every few minutes. It's unusable at this time, it won't even load a speed test it's that slow. I have tried so many different ways to communicate this to you and have got nowhere. I was supposed to receive a replacement router which hasn't turned up yet. I paid extra to have the superhub and I get next to nothing on this connection. I'm in the same situation I was in April.
Community Team

Hi Pixel0801

 

I'm really sorry to hear this.

 

I've contacted our warehouse team to find out why the router hasn't arrived and requested that this is dispatched as soon as possible.

 

Please can you post back on this thread tomorrow and we can check on this router order.

 

Thanks

 

Debbie