cancel
Showing results for 
would you rather see results for 
Did you mean: 
Need help?

New Wi-Fi Hub. Issue with ethernet connection.

Reply
KeithFrench
Community Star

That is absolutely fantastic news. One thing though, there is no way to unflag this from OCE attention now. If they think about replacing a router they normally seek your approval in that, so just say that you have sorted it since it was flagged. I will though PM the main OCE dealing with the hub & tell him not to bother.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

Jimboy
Team Player

@KeithFrench wrote:

That is absolutely fantastic news. One thing though, there is no way to unflag this from OCE attention now. If they think about replacing a router they normally seek your approval in that, so just say that you have sorted it since it was flagged. I will though PM the main OCE dealing with the hub & tell him not to bother.


 

 

Thanks Keith

 

My wife said .. "Just as long as it stays like that"

There always has to be a fly in the ointment .. ha-ha.

Community Team

Hi Jim

 

If all's working fine now that's great.

 

I'll mention the issue to our devices team so they are aware incase they have seen this issue in testing.

 

Thanks

 

Karl. 

Jimboy
Team Player

@OCE_Karl wrote:

Hi Jim

 

If all's working fine now that's great.

 

I'll mention the issue to our devices team so they are aware incase they have seen this issue in testing.

 

Thanks

 

Karl. 


 

Hi Karl,

 

Just a point of interest.

 

Now that I have my Wi-Fi Hub running to my satisfaction after the router reset, I had a look around the Hub advanced settings and discovered that Static DNS Server Configuration was set to ON.
The primary Static DNS server was set to 192.168.1.1 (same as my default gateway address). The secondary static DNS server box was empty.

 

I am no expert but it is my understanding that Static DNS should only be set to ON when one wants to use their own choice of DNS servers rather than those automatically provided by the ISP.

 

 I decided to turn it to OFF and rebooted my PC to activate the change, expecting it to revert to Automatically Assigned DNS Servers, but, on reboot, I found that my PC would no longer connect to the internet (same behaviour as before).

 

I then re-activated Static DNS Server Configuration to ON and set the primary box to same as before (192.168.1.1) and also populated the secondary box with 79.79.79.80, one of the normally automaticaly assigned addresses, and, after PC reboot to activate the settings, all is well.

 

Throughout my 'experimentations' I found that wifi worked well on all of my wifi devices, regardless of the DNS settings.

 

In conclusion, my Windows 7 pc will only connect to the internet via ethernet cable when the Wi-Fi Hub is set to Static DNS servers. (Which is fine by me)

 

Sorry about the long 'blog' and I realise my 'discovery' might well be unique to my particular setup but I thought it might be of interest to your  'devices team so they are aware incase they have seen this issue in testing.'

 

Regards .. Jim.

 

 

 

 

KeithFrench
Community Star

Hi @Jimboy

 

Don't change the DNS servers there, although not clearly worded it gives you a clue by being 192.168.1.1. This is the IP address handed out to all of your devices via DHCP telling them to use 192.168.1.1 as their DHCP server - the DHCP server built into the router. Leave the 2nd DHCP server box blank.

 

If you do want to change the network DNS servers that the router uses (e.g. Google on 8.8.8.8 & 8.8.4.4) this is done via:-

 

Dashboard

See internet settings or See W-Fi settings or Manage my devices

 

Click on the Manage advanced settings button to get to the TalkTalk WiFi hub page:-

Click on Internet connectivity:-

TalkTalk WiFi Hub - Internet connectivity.png

 

 

 

This loads the Basic internet connectivity page, where the network DNS servers can be configured:-

Internet Connectivity.png

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

Jimboy
Team Player

Hi Keith. Thanks for that.
 
At the risk of boring you (or anyone else who might be reading this) I can see my settings on that page are in fact set to Obtain DNS Automatically. The servers are set at the default TalkTalk DNS settings. I can now see how to change them if I so desire.
 I think my Static DNS settings are overriding that. Perhaps that's to be expected?

 

I have a small program called DNS Benchmark which tells me what DNS servers I am actually using to access the internet and how they compare with others.

Before I 'fiddled' with my settings, it told me that I was using 192.168.1.1 (which was the fastest on the comparison list). It also told me that it was the sole DNS server and recommended I add a secondary one as 'back up'.
So I then added 79.79.79.80 to the wifi hub Static DNS Server Configuration as the secondary entry and re-ran Benchmark. The result tells me that my system is now using both of those DNS servers and that those ' System nameservers are faster than ALL puplic alternatives' and  'This system's nameservers are 100% reliable.

 

I was tempted to try changing them in the internet connectivity page just to see what happens, but given all is working well with my present settings I am of the mind that 'If it aint broke why fix it?' I'm too much of a coward .. ha-ha.

 

Thanks again .. Jim.

geekysteve
First Timer

Hi

 

Just to let you know I am having the same issue. Frequently losing DHCP on wired devices on my home network but wifi attached devices working fine. Particularly frustrating as I am running Plex on a hard-wired NAS so completely lose access to my entire media library and have to keep rebooting the router. Tried logging to TalkTalk but similarly keep getting asked irrelevant questions about my wifi - how far am I from the router, etc. Sorry I have no answers for you but wanted you to know I fully understand and share your pain.

Arafat
First Timer

Thanks Jim! Adding the 2nd DNS and rebooting my laptop seems to have resolve my issue

matt617
Popular Poster

I also have a router which will not allow devices to connect to the internet (or even each other) through wired connections.

 

I have a Synology NAS and Macbook, neither of which can get internet access via the router. 

 

The router thinks the devices are connected fine, and devices can use wifi with no problems.

 

I've tried resetting, configuring static DNS, nothing works.

 

I had to deal with customer services on the first day because the new line took much longer to get running than I was told when taking out the contract. The service agent on that call was so bad that I very nearly considered cancelling the service immediately. Between that and reading the comments about TalkTalk's service on this forum, I think I should probably get out of this contract while I can - before my 30 days cooling-off period elapses.

 

If anyone from technical support can offer some alternative steps to try then please let me know.

ferguson
Community Star

@matt617 You have posted on an old thread here, if you would like the support team to look into your issue then it is best to start your own topic.

matt617
Popular Poster
Thanks, will do