cancel
Showing results for 
Show  only  | would you rather see results for 
Did you mean: 
Need help?

No power to router

Reply
7 REPLIES 7
Highlighted
First Timer

Hiya
I recently switched from ~Sky to TalkTalk, got sent my new router yesterday and set to go live today, plugged everything in, following the set up etc this morning and I'm getting 0 power to the router, nothing at all. Pretty disappointing and now I'll be left without internet, really not great first impression from switching and unsure what to do now..

Highlighted
Community Star

Hi Luckily, welcome to the community your post has been flagged for assistance and you should hear during the day. In the meantime please check your community profile and add your landline phone number if necessary it is used to identify your account.

As a temporary fix it you still have the sky router try using that till your talktalk kit is sorted

I don't work here and all my opinions are my own.
Highlighted
Community Team - TT Staff

Hi

 

does no light come on at the front of the router at all.  Have you tried in another plug socket etc ?

 

Thanks

 

Karl. 

Check & Report l Our latest Blog l Set Your Preferences l Service Status l Help with your Service l Community Stars

Working From Home Tips


Please log in to My Account if you need to view or pay your bill, manage boosts and track your usage. From My Account you can also check your connection and test your line for any issues in the Service Centre.


WEAR A MASK      -      WASH YOUR HANDS      -      SOCIAL DISTANCE

Highlighted
First Timer

I'm at work at the moment so I will try this when I'm home thanks!

Highlighted
Community Team - TT Staff

No Problem 🙂

 

As soon s you can confirm we can get things sorted for you.

 

 

Karl 

Check & Report l Our latest Blog l Set Your Preferences l Service Status l Help with your Service l Community Stars

Working From Home Tips


Please log in to My Account if you need to view or pay your bill, manage boosts and track your usage. From My Account you can also check your connection and test your line for any issues in the Service Centre.


WEAR A MASK      -      WASH YOUR HANDS      -      SOCIAL DISTANCE

Highlighted
First Timer

All seems to be fine and working now  sorry for any bother  

Highlighted
Community Star

Brilliant glad it is all sorted

I don't work here and all my opinions are my own.
Highlighted
Community Team - TT Staff

Hi luckiineko

 

Thanks for keeping us updated, please let us know if you do experience any further issues.

 

Debbie 🙂