cancel
Showing results for 
would you rather see results for 
Did you mean: 
Need help?

IPv4 Port Mapping - DG8041W Hub

Reply
33 REPLIES 33
Highlighted
Team Player

How do you please port map 443 to a particular internal host? Everytime I try on this new TalkTalk Black hub, I get frustrated by this error:

 

error.png

Highlighted
Community Star

You have to do port translation on both TCP ports 80 & 443 on this router. Try setting up the external port to something like 9443 and leave the internal port as 443. Then you will have to test 9443 in a port checking website.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

Highlighted
Team Player

Many thanks for reply, I can indeed change the external port and get the port forward to apply that way. However, I cannot then change the port my (Outlooksync) application is coming in on, it uses 443 and I can't change that to use 9443 for example instead. Is it not possible on this router to direct something coming in on 443 (or 80 then) to a particular interal host?

Highlighted
Community Star

No sorry because as soon as you try to use port 443 as an external port, it says it conflicts with an internal port. Both 80 & 443 are used by the router's web management UI, which is fairly common with Huawei routers. if this is crucial, the original WiFi Hub (Sagemcom FAST5364) will allow you to do what you want.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

Highlighted
Team Player

Thanks again, it is not the answer I wanted of course, but it is really helpful to at least get a definitive answer. I'll spare the embarrassing 'answers' provided to me through an hour of TalkTalk tech chat support before getting cut off!

 

This is all very dissappointing having just come across from another ISP. This all seems like really basic capability not supported by their hubs. Why do they even have these as port forward applications you can pick if they can't actually be used?

 

As it happens, I also want to internally host a tiny personal web site for my own use. It seems then I won't be able to do that even without putting the host on the DMZ and falling back to Windows firewall to protect it.

 

I fear I'm going to be speaking to TT about cancelling and moving to someone else again. I could buy another router of my own choosing, but that really shouldn't be necessary I'd have thought.

Highlighted
Community Star

I have now raised this with the developers.

 

If you want I can ask the OCEs to consider swapping your current hub for the previous one, the Sagemcom FAST5364, which does forward 80 & 443 without any translations being required?

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

Highlighted
Team Player

That sounds incredibly helpful and mean I might persist with TT, thank you. If they would do that, do you know, would I lose any significant performance improvements or other features reverting to the previous model? Do you think I might then get the new model returned if the developers fix this problem? 

Highlighted
Community Star

It is a very similar specification, it does have a few bugs outstanding on it, but I am hopeful that these will be fixed in the next firmware release, but as a customer, I can give no guarantees or timescales. I used it for quite a while and my main criticism is that it is not as configurable as the model you have. Your last question I cannot answer. If you to give the Sagamcom a go, let me know.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

Highlighted
Community Team - TT Staff

Hi Jump666

 

Would you like me to send the replacement router for testing?

 

Thanks

 

Debbie

Highlighted
Team Player

Thanks for the offer Debbie, yes please. That does seem the best way forward without finding myself running into further problems. I really didn't expect this problem with the current hub, and until the fantastic help from Keith didn't know it was a 'limitation' of that or my own skills. I'd really welcome getting this resolved now.

Highlighted
Community Team - TT Staff

Hi jump666,

 

Can you please update your community profile to include your:

  • Name
  • Telephone number
  • Alternative contact number

We'll then arrange to send the router. Please do not post this information on this thread Once you've updated your profile please post in your topic to confirm it's updated. 

 

Thanks

Chris

Highlighted
Team Player

OK, I have now done that thanks

Highlighted
Community Team - TT Staff

Hi Jump666,

 

I've ordered the router, it should be with you within a couple of days but please allow up to 5 working days for delivery


Thanks

Chris

Highlighted
Team Player

Hi Chris - reporting safe receipt of the replacement router thanks, which is immediately preferred over the 'newer' TT router originally supplied. Had it all up and running within 15 minutes, including mapping port 80 and 443, which was not possible before.

 

However, just one issue if you can help please. How do I reserve IP addresses? I have two devices I want to reserve addresses for. Ironically I could do that with the originally supplied router, but just can't seem to find the option on this model!

 

This new hub is software version SG4K10001400t - do I need a firmware upgrade?

 

Highlighted
Community Star

That version does support DHCP reserved IP addresses, you really need v2808. It should update overnight, but if not, try a reboot. Failing that I will ask the OCEs to do it for you.

Keith
I am not employed by TalkTalk, I'm just a customer. If my post has fixed the issue, please mark it as the Best Answer.
OCE's and Community Stars - Who are they? 

Highlighted
Community Team - TT Staff

Hi Jump666,

 

I can see that your router firmware is now updated. If you need any further assistance please let us know 

 

Chris

Highlighted
Team Player

Thanks for the confirmation Chris and the further brilliant informed advice from Keith, I have logged in since the upgrade and see exactly what I hoped might be there to reserve IP addresses. However, I've unable to test as a really bad problem seems to have appeared in the upgrade to thwart my efforts.

 

The 2.4GHz keeps failing completely, all devices are suddenly losing connection and will not then reconnect. I have been able to turn off the wireless setting and everything reconnects when I turn it back on, but only for everything to fail again within an hour. What is going on, it is proving really bad. Twice on turning the WiFi off as well the hub has just crashed... The 5GHz and direct wired connection seem unaffected.

Highlighted
Community Team - TT Staff

Hi Jump666

 

I'm really sorry to hear this.

 

Have you also tried factory resetting the router using the pin hole reset?

 

Thanks

 

Debbie

Highlighted
Team Player

Hi Debbie - before I do that, can you confirm please that there is genuine cause to believe this will resolve the issue as a factory reset will require me all the subsequent effort of configuring the hub again afterwards, wireless settings, port forwards, fixed addresses etc. This is all a fair pain and not something you want to do if it is essentially just a harder version of the 'try turning it off and on again' approach...

Highlighted
Community Team - TT Staff

Hi Jump666

 

I've checked and this could be our line optimisation changing the wireless from 2ghz. 

 

Our Products Team have advised if you are experiencing issues and would prefer to select your own wireless channels then we can arrange for Wi-Fi optimisation technology to be switched off on your line.

 

Thanks

 

Debbie