cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

FIbre Support

Get expert support with your Fibre connection.

Forum Posts

Weak security warning on AppleIOS and Windows 10 or 11

Some Apple products have recently had an upgrade that can show the WiFi connection as having weak security:- iPad Software Version 14.01 - since the update to Version 14.0 it has shown Weak Security iPhone SE Software Version 14.01 -since the update ...

Privacy warning - this network is blocking encrypted DNS traffic

This subject is involved & not knowing how much you know, or want to know about it, I will try to explain. When you type a website address URL in the browser this must be converted to an IP address, as the URL is not rotatable, only an IP address is....

Change of Account Name

I've just joined TalkTalk but my account name has been entered wrongly. How can I change it? The only option I see is for a downloadable form with proof of the change but the error is not mine. Thanks.

Moving home

Hello there I am moving from my current address this 2nd April and I would like to be a talk talk #fiber brodband customer what should I do Thank you

Clement2 by First Timer
  • 180 Views
  • 3 replies
  • 0 like

Cannot connect to DHCP server

Ok, so my fibre broadband stopped working on Thursday 15th February. Went through the live chat to try to fix the issue. Restarted Eero router, restarted ONT box, factory reset of the Eero router, but none of that worked. I tried a second Eero router...

fibre optic cables to my house tomorrow.

Can you confirm that fibre optic cables will be fitted to my house tomorrow, Tuesday 30th. Received a telephone call but wonder if this is correct as I have not heard anything from Talktalk direct.

AngelaR by First Timer
  • 219 Views
  • 2 replies
  • 0 like

Can’t connect to any website/app

Hey, i’m needing some help as for some reason all my apps and websites have become useless as my talktalk WiFi is stating “This site can't provide a secure connectiondictionary.cambridge.org sent an invalid response.ERR_SSL_PROTOCOL_ERROR” meanwhile ...

IMG_8175.png IMG_8173.png IMG_8174.png
Choice by Participant
  • 1881 Views
  • 33 replies
  • 0 like

Password not recognised

I have bought a new iPhone and I am trying to set it up but my wi-fi password is not recognised. The internet and email works perfectly but the new phone does not accept my password. I have been very careful when putting the password in.

Resolved! Not receiving Verification Code emails since Wednesday

Hi Guys, Firstly, sorry if I have used the wrong section to post in. Please move if needed. I hadn’t been on the community for some time, but Tuesday and Wednesday I received the Verification Code emails allowing to post comments on here. Since Thurs...

Loss of internet

Hi,I hope you can help me, I suddenly lost internet connection around 11am today, my phone line is working, I then rebooted my modem and eero router and when it's still not working I went on live chat and it's been over 4 hours now I keep getting pas...

Unstable internet

HelloMy internet has been unstable for the last 2 weeks, this is the first time I've been able to get to this page because the site never loads.Please can you sort this out?I've tried all the suggested fixes, nothing works. The constant outages have ...

lynne14 by First Timer
  • 717 Views
  • 6 replies
  • 0 like

Resolved! Using a modem and Ubiquiti USG - settings

Hi, my Talk Talk connection has stopped working with my modem and router - a Draytek Vigor130, and a Ubiquiti USG. All was working well until a week or so ago when the connection dropped. It seems there was an external fault, but eventually that seem...

No Internet - Flashing Orange and Blue light

Hello! We’ve had no internet since the 2nd May and the router just continuously flashes orange and blue. Performed many troubleshooting steps as listed below: - Tried resetting- Tried Factory Reset via physical pin- Left the router device off for ove...

Fibre not working since installation

   Hi, I had Fibre 150 installed 6 Days ago and I have not been able to connect to it via my Eero 6 or my old talktalk router via the Red WAN. Openreach have been out and checked its all installed properly but apart from that no one seems to know wha...

20230416_140124.jpg 20230419_205909.jpg Screenshot_20230416_134852_eero.jpg
MickyB93 by Popular Poster
  • 1992 Views
  • 17 replies
  • 0 like

Talk Talk Ultra Fibreoptic

We've had what was at the time, York Fibre, ever since it was available. At some point this switched over to Talk Talk and we've been with them ever since. I recently received an email saying that our contract has expired and (surprise surprise) the ...

paimon9 by First Timer
  • 294 Views
  • 1 replies
  • 0 like

Warning Intrusion / cyber attack

hiall of a sudden i started having issues with my connection last night and when I look I had a lot of Intrusion security alerts, that keep coming up every 10 mins(ish) .(see below for first lot), also on the log was things like a IP spoofing 192.168...

GuyOnMars by Popular Poster
  • 1735 Views
  • 16 replies
  • 0 like

Resetting password for TalkTalk community

My partner want to raise a topic in the Community but cannot login because she has forgotten her password. She has tried the reset password option with her registered email account but nothing is being received. She's tried several times and has chec...

TOCTOC by Team Player
  • 1763 Views
  • 20 replies
  • 0 like